PHP Classes

PHP 7.2 compatibility

Recommend this page to a friend!

      POP3 e-mail client  >  All threads  >  PHP 7.2 compatibility  >  (Un) Subscribe thread alerts  
Subject:PHP 7.2 compatibility
Summary:Class not working properly in 7.2
Messages:3
Author:Klemen
Date:2018-06-21 11:59:56
 

  1. PHP 7.2 compatibility   Reply   Report abuse  
Picture of Klemen Klemen - 2018-06-21 11:59:56
Hello,

I've been using this class for years and it worked great.

Currently I upgraded from PHP 5.6 to 7.2 and it no longer works (nothing else changed). I am getting errors like:

fopen(pop3://0/1): failed to open stream:"pop3_stream::stream_open" call failed

Or

feof(): pop3_stream::stream_eof is not implemented! Assuming EOF

when using "while (!feof($fp))" on the stream.

Has anyone had similar experience or is running the POP3 class successfully on PHP 7.2?

Thank you

  2. Re: PHP 7.2 compatibility   Reply   Report abuse  
Picture of Manuel Lemos Manuel Lemos - 2019-07-18 03:47:33 - In reply to message 1 from Klemen
Hello Klemen,

Sorry for the huge delay. I don't know if this will still be useful for you but I will soon have to upgrade packages like this that I use in my projects and also need to upgrade to PHP 7.x.

Can you please ask me here again next month, so I can give you the status of updating packages like this?

  3. Re: PHP 7.2 compatibility   Reply   Report abuse  
Picture of Max Mustermann Max Mustermann - 2019-07-23 12:34:49 - In reply to message 2 from Manuel Lemos
Hello Manuel,

I want to upgrade to PHP7.3 / PHP7.4 in future too. Still using PHP5.6 and have not started any upgrade-tests. I will have a look at this thread also :-)

Best regard
Olli

 
For more information send a message to info at phpclasses dot org.